Homebrewers Association | AHA Forum

General Category => General Homebrew Discussion => Topic started by: scottgott01 on May 03, 2012, 03:45:34 PM

Title: Aroma Trouble
Post by: scottgott01 on May 03, 2012, 03:45:34 PM
Hi Guys,

I have been extract brewing for about a year now. I wouldn't call my self a pro but I think I almost past the novice stage in this area. I am getting ready to begin all grain brewing. I am running into one issue though and I am curious if it will resolve when I switch to all grain and if it is common with extract brewing. I cannot seem to get a good aroma when brewing with extracts. My beers always have a yeasty smell to them. I don't get the nice hop aromas or malt aromas you get from store bought craft beers. Is this due to my extract brewing? Will the aroma come when I switch to all grain?

Please note my beers all taste perfectly fine.

In other forums some people have told me my hop addition times might be off (perhaps some flame out or dry hopping). Some also told me it might be a water or ferm temp issue.

One question besides the above:

What is a good way to maintain temp outside of a ferm chamber (I plan on making one in a few months), I live in PA. So I have all 4 seasons to deal with. I usually ferment in my basement as it is dark and usually cool (ranges from coldest in the winter at 60 degrees to warmest in the summet at 74 degrees with a +/- 5 degree range in the summer).
Title: Re: Aroma Trouble
Post by: Hokerer on May 03, 2012, 04:16:53 PM
Extract brewing is almost certainly not your issue.

Would need more info on your processes to help figure out what is.  Fermentation temp control could certainly have something to do with it.  Particularly if the severity of your issue varies over the course of the year.
Title: Re: Aroma Trouble
Post by: Joe Sr. on May 03, 2012, 04:32:16 PM
I agree it's not extract.  I use a LOT of extract and don't have this issue.

Something else must definitely be going on.

As to temp control, try putting the carboy in a tub of water.  You can add frozen one or two liter bottles of water to bring the temp down to where you want it.
Title: Re: Aroma Trouble
Post by: andrew000141 on May 03, 2012, 04:47:21 PM
You said it was a yeasty smell? what kind of yeast are you using and if its dry do you rehydrate it? and +1 to the tub of water.
Title: Re: Aroma Trouble
Post by: morticaixavier on May 03, 2012, 05:05:06 PM
+1 on more process info. But a yeasty smell says to me that you are not waiting long enough. The beer shoudl stay in primary until 2 gravity readings a few days apart are the same + a week or 2 longer. Even after the vast majority of sugars have been fermented the yeast is still active and working on cleaning up your beer.

try this on your next brew

after 2 weeks take a gravity reading, then wait another week, take another reading. If it has changed wait another week and take another reading. When they stop changing wait 1 more week, add some dry hops to the primary (either in a sanitized hop bag, or just chuck them in there). wait 1 more week, bottle or keg as usual, let it carbonate up (a couple more weeks if priming with sugar) then let it sit in the fridge for a few days and taste it.
Title: Re: Aroma Trouble
Post by: scottgott01 on May 03, 2012, 06:20:47 PM
Well, I know time in the fermenter is very important. I usually leave a batch in the fermenter no less than three weeks. So I know thats not my problem. As far as fermentation temp and the tub of water. Do I leave it in the tub the whole time I am fermenting.

Another issue which I was thinking about. Sometime I pitch the yeast warmer than 75 degrees. I wonder if that could be my issue?
Title: Re: Aroma Trouble
Post by: tomsawyer on May 03, 2012, 06:28:45 PM
Pitching warm is a way to get esters, but I don't hear you complaining about this.

You can take the beer out of the swamp cooler after the peak of fermentation is over.

As for aroma, what temp do you typically serve your beer?  Serving cold really mutes the aroma.  Try it at 50F.

Finally, I too struggle with getting the kind of malt flavor and aroma you find in a really well made craft beer.  I am looking at the possibility of oxidation as a culprit.  You mention leaving the beer in primary for three weeks.  If its a bucket you might consider transferring to a carboy after a week, but be sure to rack over a good amount of the yeast cake so the fermentation doesn't stall out.

And hey, at least your beer doesn't semll like vomit.  I'll be glad when that thread dissappears from page one.
Title: Re: Aroma Trouble
Post by: scottgott01 on May 03, 2012, 06:40:33 PM
Lol, I was just reading the "My homebrew smells like vomit" thread. Hahaha. Good stuff. I am going to try dry hopping my next batch with a mix of citra and cascade (the two I am using im my boil). Or maybe I'll just stick to dry hopping with Cascade since that has more of an aroma character than citra.
Title: Re: Aroma Trouble
Post by: skyler on May 04, 2012, 05:12:59 AM
Don't pitch so warm f you don't want esters. It's better to wait over night and get the right temp if you have to. At least try getting it to 68F or so.

Citra is an exceptional aroma hop and great for dry hopping.
Title: Re: Aroma Trouble
Post by: scottgott01 on August 02, 2012, 02:39:28 PM
For those of you who helped me out on this thread. My problem most definetely was not cooling my wort soon enough. I made myself an emersion chiller (not the prettiest thing), but it takes my wort from boiling to 70 degrees in under 10 minutes (5 gallon batch). I have not had an aroma issue in the past 4 batches I have made. I appreciate the help. Get my MLT next week. Godspeed my friends
Title: Re: Aroma Trouble
Post by: cfleisher on August 14, 2012, 06:08:17 AM
+1 on more process info. But a yeasty smell says to me that you are not waiting long enough. The beer shoudl stay in primary until 2 gravity readings a few days apart are the same + a week or 2 longer. Even after the vast majority of sugars have been fermented the yeast is still active and working on cleaning up your beer.

try this on your next brew

after 2 weeks take a gravity reading, then wait another week, take another reading. If it has changed wait another week and take another reading. When they stop changing wait 1 more week, add some dry hops to the primary (either in a sanitized hop bag, or just chuck them in there). wait 1 more week, bottle or keg as usual, let it carbonate up (a couple more weeks if priming with sugar) then let it sit in the fridge for a few days and taste it.

Totally agree with everything said here. If you've got a yeasty aroma, then you may not be giving the yeast enough time to "do its thing."
Title: Re: Aroma Trouble
Post by: AmandaK on August 15, 2012, 03:34:10 PM
For those of you who helped me out on this thread. My problem most definetely was not cooling my wort soon enough. I made myself an emersion chiller (not the prettiest thing), but it takes my wort from boiling to 70 degrees in under 10 minutes (5 gallon batch). I have not had an aroma issue in the past 4 batches I have made. I appreciate the help. Get my MLT next week. Godspeed my friends

Thanks for posting a resolution. Perhaps the "yeasty" smell was DMS after all.