Homebrewers Association | AHA Forum

General Category => General Homebrew Discussion => Topic started by: bassface74 on March 16, 2010, 05:33:39 PM

Title: RO Water and additives
Post by: bassface74 on March 16, 2010, 05:33:39 PM
I use RO water for brewing, should I be adding anything to that type of water for hardness....etc?  My brews are just extract using steeping grains so it's nothing too crazy.  My first two batches seemed to finish a little "off" in flavor so I thought I would see if it may be my water.  It does taste fine though.
Title: Re: RO Water and additives
Post by: Kaiser on March 16, 2010, 05:39:41 PM
I don't think the off-flavor comes from the lack of salts. The only salt that may be benefical to you is gypsum (calcium sulfate). The additional sulfate is known to accentuate the hop presence. Aside from that the extract contains all the minerals you need.

Kai
Title: Re: RO Water and additives
Post by: euge on March 16, 2010, 06:45:55 PM
I use RO water for brewing, should I be adding anything to that type of water for hardness....etc?  My brews are just extract using steeping grains so it's nothing too crazy.  My first two batches seemed to finish a little "off" in flavor so I thought I would see if it may be my water.  It does taste fine though.

Describe "off-flavor" please?

It could be oxidized extract.
Title: Re: RO Water and additives
Post by: bassface74 on March 16, 2010, 07:24:04 PM
Not sure, kind of old I guess.  It just didn't taste right.  I am thinking I got some extract that was a little too old on the shelf?
I made a pilsner.

I have yet to taste the english brown ale I made for my 2nd brew, maybe that one will turn out.

I have also switched to using star san so i might have gotten some contamination since I'm still green at doing this.
Title: Re: RO Water and additives
Post by: dimik on March 16, 2010, 07:41:03 PM
I used RO water with no additives when doing extracts, and had no problems.
My guess is there is something with your procedure... ferm temps perhaps? Or it could be old extract.
Title: Re: RO Water and additives
Post by: Beertracker on March 16, 2010, 10:59:27 PM
It's doubtful that your "off-flavor" is coming from your RO water. Sounds like either the extract was stale (+1) or you inadvertently aerated your finished beer causing oxidation. Use of some epsom salt may also be beneficial in future brews, as it again contributes to a beer's crispness and adds nutrients for the yeast.  ;)