Homebrewers Association | AHA Forum

General Category => Pimp My System => Topic started by: tommymorris on September 29, 2019, 02:36:21 PM

Title: Picobrew Z1 Bad Day
Post by: tommymorris on September 29, 2019, 02:36:21 PM
Dry grain in the step filter this morning after mash and boil. Not too pleased. 1030 SG when expecting 1050.  I am going to try a 1070 batch and mix the two. Fingers crossed.

(https://uploads.tapatalk-cdn.com/20190929/b084a4a8199d05dd0aad447714bcab13.jpg)
Title: Picobrew Z1 Bad Day
Post by: BrewBama on September 29, 2019, 07:22:09 PM
That sux. Any ideas why this happened so it doesn’t happen again?

Edit: I read that you might consider programming a stop point to remove the step filter and stir the grain after mash-in to eliminate dry pockets and low efficiency.

Sent from my iPhone using Tapatalk
Title: Re: Picobrew Z1 Bad Day
Post by: tommymorris on September 30, 2019, 02:17:24 AM
That sux. Any ideas why this happened so it doesn’t happen again?

Edit: I read that you might consider programming a stop point to remove the step filter and stir the grain after mash-in to eliminate dry pockets and low efficiency.

Sent from my iPhone using Tapatalk
I don’t know what the problem is. The Picobrew is unable to recirculate water/wort right now.  Something is plugged up or it isn’t getting suction. I am not sure.

I will have to contact Picobrew for help.
Title: Picobrew Z1 Bad Day
Post by: BrewBama on September 30, 2019, 04:01:30 AM
It’ll be something simple.

Any updates?

Sent from my iPhone using Tapatalk
Title: Re: Picobrew Z1 Bad Day
Post by: tommymorris on October 05, 2019, 06:47:34 PM
It’ll be something simple.

Any updates?

Sent from my iPhone using Tapatalk
Still dead. Picobrew wants a video of the machine running so they can evaluate. I haven’t had a chance to upload a video. Traveling too much right now.

I believe a pump or line is clogged.
Title: Re: Picobrew Z1 Bad Day
Post by: tommymorris on October 13, 2019, 02:16:03 PM
It’ll be something simple.

Any updates?

Sent from my iPhone using Tapatalk
Still dead. Picobrew wants a video of the machine running so they can evaluate. I haven’t had a chance to upload a video. Traveling too much right now.

I believe a pump or line is clogged.
I believe I finally found the problem. The red rubber gasket in this picture has somehow gone missing. I thought it was missing but there is no mention of it in the Z manual. I had asked PicoBrew support about it but they just kept going down their checklist and didn’t answer. Finally, I asked on a forum and got an answer the day before PicoBrew support got there on the check list and sent me this picture.

(https://uploads.tapatalk-cdn.com/20191013/9b8045284ffbbfcc7d6f62255fd40ba2.jpg)

PicoBrew puts spares for many small pieces in the Z1 box, but, not this one. I am waiting until Tuesday to hear back from PicoBrew about the size of the gasket or whether I can buy a spare. For now, I have crafted a stand-in from some tubing.

With my work around the PicoBrew Z1 works properly again. Without the gasket there is a not a good seal and the in take pump could not pull liquid.
Title: Re: Picobrew Z1 Bad Day
Post by: BrewBama on October 13, 2019, 02:56:21 PM
Yep. Something simple. You can buy a hundred of those and never need another one. But don’t have a spare of something else simple and that’s what you’ll need. At least that’s the way it works around here.

Glad you got it up and running.

How did the Peaty Wheatstraw turn out?


Sent from my iPhone using Tapatalk
Title: Re: Picobrew Z1 Bad Day
Post by: denny on October 13, 2019, 04:09:30 PM
I think I have some spare filter o rings around.  PM me if you need one.
Title: Re: Picobrew Z1 Bad Day
Post by: tommymorris on October 14, 2019, 12:16:53 PM
Yep. Something simple. You can buy a hundred of those and never need another one. But don’t have a spare of something else simple and that’s what you’ll need. At least that’s the way it works around here.

Glad you got it up and running.

How did the Peaty Wheatstraw turn out?


Sent from my iPhone using Tapatalk
Peaty Wheatstraw is pretty good. It debuts tonight at a club competition. 95% Wheat malt, 5% C60 and a bunch Mosaic and Crystal. I brewed it as an APA with 1050 OG. The hops and beer flavors are great. The beer comes off just a little thin. But, overall I am surprised the lack of barley base malt is not very noticeable (except maybe the thinness?).
Title: Re: Picobrew Z1 Bad Day
Post by: tommymorris on October 14, 2019, 12:18:15 PM
I think I have some spare filter o rings around.  PM me if you need one.
Thanks for the offer. I’ll wait on Picobrew first. I think/guess they will offer to send some free. The person I am working with is off today. I think I will here tomorrow.
Title: Re: Picobrew Z1 Bad Day
Post by: denny on October 14, 2019, 01:59:03 PM
I think I have some spare filter o rings around.  PM me if you need one.
Thanks for the offer. I’ll wait on Picobrew first. I think/guess they will offer to send some free. The person I am working with is off today. I think I will here tomorrow.

Are you talking to Kevin?
Title: Re: Picobrew Z1 Bad Day
Post by: tommymorris on October 14, 2019, 03:26:02 PM
I think I have some spare filter o rings around.  PM me if you need one.
Thanks for the offer. I’ll wait on Picobrew first. I think/guess they will offer to send some free. The person I am working with is off today. I think I will here tomorrow.

Are you talking to Kevin?
No I have been working with Tim. He is doing well. I am guessing they have grown and there is more than one technical support now.
Title: Re: Picobrew Z1 Bad Day
Post by: denny on October 14, 2019, 03:50:52 PM
I think I have some spare filter o rings around.  PM me if you need one.
Thanks for the offer. I’ll wait on Picobrew first. I think/guess they will offer to send some free. The person I am working with is off today. I think I will here tomorrow.

Are you talking to Kevin?
No I have been working with Tim. He is doing well. I am guessing they have grown and there is more than one technical support now.

Yeah, but Kevin's the best.
Title: Re: Picobrew Z1 Bad Day
Post by: tommymorris on October 14, 2019, 04:13:27 PM
I think I have some spare filter o rings around.  PM me if you need one.
Thanks for the offer. I’ll wait on Picobrew first. I think/guess they will offer to send some free. The person I am working with is off today. I think I will here tomorrow.

Are you talking to Kevin?
No I have been working with Tim. He is doing well. I am guessing they have grown and there is more than one technical support now.

Yeah, but Kevin's the best.
Kevin helped me once before. He is good.
Title: Re: Picobrew Z1 Bad Day
Post by: tommymorris on October 28, 2019, 04:50:51 PM
Follow up: I received a replacement for my lost gasket. I brewed this weekend. All is well.

Picobrew sent me two new gaskets and an extra drain tube grommet. One of mine was damaged. I still think a mouse took a bite out of piece.

I think my learning curve on the Z1 has taught me air and liquid tight seals are key to Z1 success.
Title: Re: Picobrew Z1 Bad Day
Post by: BrewBama on October 28, 2019, 04:57:01 PM



Sent from my iPhone using Tapatalk
Title: Re: Picobrew Z1 Bad Day
Post by: Robert on October 28, 2019, 06:50:15 PM



I think my learning curve on the Z1 has taught me air and liquid tight seals are key to Z1 success.

And having a cat to take care of those mice!    Glad all is resolved.
Title: Re: Picobrew Z1 Bad Day
Post by: tommymorris on October 28, 2019, 06:51:06 PM



I think my learning curve on the Z1 has taught me air and liquid tight seals are key to Z1 success.

And having a cat to take care of those mice!    Glad all is resolved.
Good point.
Title: Re: Picobrew Z1 Bad Day
Post by: BrewBama on October 28, 2019, 07:01:03 PM
I had a cat show up here on a brewday years ago. He has definitely earned his keep. He’s forever bringing his trophies to the back door. ...and I love it when he patrols the basement.


Sent from my iPhone using Tapatalk