Homebrewers Association | AHA Forum

General Category => Yeast and Fermentation => Topic started by: dannyjed on March 22, 2020, 01:02:47 pm

Title: Help Me Fix this Sulfur Aroma
Post by: dannyjed on March 22, 2020, 01:02:47 pm
I have a German Helles that I just put on tap and it has quite a bit of sulfur on the nose and not in the flavor. I was wondering if this will eventually age out or is there a better solution to get rid of it. It's a basic recipe of Pilsner Malt and Hallertau Tradition hops. The yeast is WY2124 which I've never had this much sulfur aroma before. I fermented it at 50 degrees and even did a d-rest at 60 for a few days. Any suggestions?
Title: Re: Help Me Fix this Sulphur Aroma
Post by: denny on March 22, 2020, 01:18:42 pm
IME, a dream will have no effect on sulfur.  And you might wamt to try a higher temp for it next itme.  I've heard reports of sulfur being diminished by putting the beer in donate briefly with copper.  That's about all I know about it, though.  Bubbling CO2 through it could also help.  I usually just wait for it to diminish on its own, which it almost always seems to.
Title: Re: Help Me Fix this Sulfur Aroma
Post by: jeffy on March 22, 2020, 01:38:22 pm
There has been some discussion on this forum of dropping some copper into the beer to remove sulphur.  It sounds easy.  Let us know if that works.
Title: Re: Help Me Fix this Sulfur Aroma
Post by: BrewBama on March 22, 2020, 02:25:04 pm
https://www.homebrewersassociation.org/forum/index.php?topic=9514.0


Sent from my iPad using Tapatalk
Title: Re: Help Me Fix this Sulfur Aroma
Post by: dannyjed on March 22, 2020, 02:56:01 pm
Thanks for the link to that thread Brewbama. I notice that sulfur aroma dissipates after the beer is in the glass for a little while. So, I think it will hopefully diminish over time. I could try putting some copper in the next glass and see what happens. I just don’t want to open up the keg and allow Oxygen intake.


Sent from my iPhone using Tapatalk
Title: Re: Help Me Fix this Sulfur Aroma
Post by: mabrungard on March 22, 2020, 05:30:54 pm
Copper does have an immediate effect on sulfury notes. The reaction only takes about a minute or two. If your system has no copper piping or parts, adding a bit of copper tubing to the kettle can preemptively avoid this problem.
Title: Re: Help Me Fix this Sulfur Aroma
Post by: dannyjed on March 22, 2020, 05:34:19 pm
Copper does have an immediate effect on sulfury notes. The reaction only takes about a minute or two. If your system has no copper piping or parts, adding a bit of copper tubing to the kettle can preemptively avoid this problem.
I use a copper wort chiller. Hopefully more conditioning will help.


Sent from my iPhone using Tapatalk
Title: Re: Help Me Fix this Sulfur Aroma
Post by: hopfenundmalz on March 22, 2020, 06:48:39 pm
A friend says a solution some pros use is to trannsfer through a hose with copper tubes packed in it. You might make a tranfer line with a copper segment in it, transfer slowly.
Title: Re: Help Me Fix this Sulfur Aroma
Post by: dmtaylor on March 22, 2020, 07:17:31 pm
Wait 3-4 weeks.  9 times out of 10, that's all that's needed is time.
Title: Re: Help Me Fix this Sulfur Aroma
Post by: dannyjed on March 22, 2020, 07:53:01 pm
Wait 3-4 weeks.  9 times out of 10, that's all that's needed is time.
That’s what I’m thinking. The beer tastes great and the sulfur aroma is off putting for the first half of the pint. Then, the sulfur notes decrease or I’m getting used to it. I think I’ll wait a week and see where it’s at.


Sent from my iPhone using Tapatalk
Title: Re: Help Me Fix this Sulfur Aroma
Post by: majorvices on March 23, 2020, 07:16:42 am
The copper thing sometimes works. Also bubbling up co2 (assuming that's possible) often works even better. Waiting sometimes works. Sometimes nothing works except holding your nose. ;)
Title: Re: Help Me Fix this Sulfur Aroma
Post by: Silver_Is_Money on March 23, 2020, 10:03:24 am
I could easily be wrong, but I have been of the opinion that when yeast toss up a bunch of sulfur notes it is often due to insufficient yeast nutrients.
Title: Re: Help Me Fix this Sulfur Aroma
Post by: Village Taphouse on March 23, 2020, 10:27:24 am
This is interesting.  I took all of the copper out of my system awhile back (now an SS wort chiller and some other pieces that had copper are now stainless too) and I do feel like there is a bit more sulfur in the beers I make but (as mentioned) it almost always ages out by itself.  Also, a good German beer does have a slight sulfur aroma to it, typically and I think it's part of its charm.  Obviously too much would be wrong.  I make a lot of lagers and 2124 throws a good amount of sulfur but the finished beers after some amount of aging show little-to-no sulfur.  YMMV.   
Title: Re: Help Me Fix this Sulfur Aroma
Post by: dannyjed on March 29, 2020, 08:27:53 pm
(https://uploads.tapatalk-cdn.com/20200330/46296eee4a6ecec4dee257e49739d43f.jpg)
And just like that the sulfur aroma is almost completely gone. Just a hint which is acceptable and not dominating at at like it was a week ago. Thanks everyone for the suggestions.


Sent from my iPhone using Tapatalk
Title: Re: Help Me Fix this Sulfur Aroma
Post by: goose on March 30, 2020, 08:07:04 am
Glad the sulfur aroma is almost gone, Dan!  I have used 2124 in my Helles exclusively and it does throw off a lot of sulfur aroma when fermenting.  Thinking on going to 34/70 the next time I make the beer so I don't have to make a huge starter.

Also, and I have posted a picture of this on the forum before, I use a copper tube with a bunch of holes drilled in it on the end of the transfer hose from the chiller to aerate  the wort going into the fermenter.  Despite smelling the sulfur during fermentation, I never notice it in the finished beer. so the copper probably helps although this is a nonscientific observation.
Title: Re: Help Me Fix this Sulfur Aroma
Post by: dannyjed on March 30, 2020, 08:12:52 am
A long time home/pro brewer from my club who specializes in German lagers said, “A good wiff of sulfur can be the sign of a nice lager to come.”


Sent from my iPhone using Tapatalk