Homebrewers Association | AHA Forum

General Category => Kegging and Bottling => Topic started by: gsandel on July 14, 2011, 04:47:37 AM

Title: beer leak
Post by: gsandel on July 14, 2011, 04:47:37 AM
I wonder if any of you have this problem.  I use the ball lock flare (threaded) quick disconnect (beer out, black).  I try to crank the nut nice and tight when connecting, but twice now, moving other kegs in or out or disconnecting for some reason loosens it...two days later I open the discover a couple of pints (or more) in the bottom of the keezer....it is so much fun to waste beer and you know how us brewers like to clean.

Has anyone had this problem?  Has anyone devised a solution?  I was thinking of using some silicone tape on the threads to insure against this...

discuss.
Title: Re: beer leak
Post by: morticaixavier on July 14, 2011, 04:50:33 AM
I did have that problem in one of my kegs, luckily I caught it early. I tightened it down and it seems to be working fine.
Title: Re: beer leak
Post by: narvin on July 14, 2011, 02:44:18 PM
I've never had this problem, and I crank it nice and tight with a wrench.

You could try one of these:

http://www.northernbrewer.com/brewing/flared-nylon-washer.html

Also, are you sure it's the nut?  Maybe the worm gear clamp needs tightening on the tubing around the barb.
Title: Re: beer leak
Post by: Joe Sr. on July 14, 2011, 04:07:25 PM
I've not had this problem with the disconnects, and I only hand tighten the nut.

You can try the nylon washer, but IME the disconnects don't require these as they already have a plastic edge that meets the flare nut.

On one of my first disconnects, this edge was not formed correctly during manufacturing, and it leaked.

Of course, Narvin is correct that it could be the clamp is not tight enough.

Hook up the gas and spray the connections with a starsan solution and you'll quickly know where exactly it is leaking.
Title: Re: beer leak
Post by: jeffy on July 14, 2011, 05:43:20 PM
I wonder if any of you have this problem.  I use the ball lock flare (threaded) quick disconnect (beer out, black).  I try to crank the nut nice and tight when connecting, but twice now, moving other kegs in or out or disconnecting for some reason loosens it...two days later I open the discover a couple of pints (or more) in the bottom of the keezer....it is so much fun to waste beer and you know how us brewers like to clean.

Has anyone had this problem?  Has anyone devised a solution?  I was thinking of using some silicone tape on the threads to insure against this...

discuss.

I hate it when this happens.
Does it leak with the black quick-connect attached?  If so I would check the o-ring at the top of the post.  If not, then the o-ring at the top of the dip tube, under the post may have failed or the spring-loaded poppet in the post is bad and leaking.
I don't think thread tape would help much.
Title: Re: beer leak
Post by: gsandel on August 01, 2011, 03:03:51 AM
the nut on the flare fitting would loosen when bumped (signaling operator error)....I put silicone tape on the threads and cinched them tight with a wrench again after moving kegs in the keezer....the tape may not be necessary if I am diligent about checking the connections before closing the hatch.  So far not a drop spilled.
Title: Re: beer leak
Post by: Kit B on August 01, 2011, 09:20:03 PM
I only hand tighten & never have trouble.

BUT...You may enjoy this comedic cycle of errors...

Last week, I picked up a used keg that was pressurized & seemed to be in perfect working order.
I decided to use that keg for a batch of IPA...Sanitized everything, reassembled & made the transfer.
I hooked up the gas to pressurize & promptly got an IPA shower, due to a bent poppet foot.
So...I relieved the pressure & cleaned up...Sanitized another keg...Transferred & pressurized.
Then, I attached the Liquid Out quick connector, just to be sure I had flow...
Once again...I took an IPA shower.
Seems my wife had found my quick connector drying on the counter top & assembled it for me, without putting the rubber ring in place.
Try again...
I grab quick connector #2...Guess what...
IPA shower, again!!!
Wife musta seen 2 connectors sitting on the counter & skipped the rubber rings, in both.
I can only assume that she thought the rings were hair binders, since they look nearly identical.
So...Luckily, I had a third connector that I was able to disassemble & verify contained a ring.
There was a lot of cleanup & laundry involved.
I will be ordering several rings, very soon.
I've already replaced all "iffy" posts & poppets.

Smile...At least you don't smell like an amarillo IPA.