Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Illini Rookie

Pages: [1]
1
First off, I hope this is the right spot. I consider myself all grain now even though I don't have all the extra equipment.

First batch with BIAB was an IPA that ended up around 55% calculated efficiency. Luckily, I was targeting a little higher gravity so the low efficiency didn't kill me.

Second batch was a Kolsch that I also targeted high. Again, I ended up low, but this time with some mild improvement (60%). Both efficiency numbers were gotten by changing the efficiency number in the brewers friend recipe calculator until my OG matched the program.

A couple of notes about my set-up and process.

10 gallon brew pot, custom bag (fiance sewed it for me) that fits well over the edges.

Grains were sent through the mill at the homebrew store, so even though I have read that grain can be practically pulverized without any fear of tannins due to the mesh of the bag, I had 'regular' crushed grain.

Mashed between 154-150 for the IPA, and 152-146 with the Kolsch. Both were stirred periodically and the temp brought up by boiling water when it dropped. I had three different thermometers (brew pot, probe, and a digital stick) and they all pretty much were around the above temps.

Mashed for 70 mins on the IPA and 80 mins on the Kolsch.

No iodine test because I don't have any.

Small sparge of grains on IPA after I pulled the bag (~2 qts at 170 over spent grains). Kolsch grains sat over a strainer, and I added all the drippings back.

Both batches ended up at the volume I wanted, so I don't think it was an issue of adding too much water.

No pH taken during the whole thing either. No dark malt to bring acidity down, but I don't think my water would lead to higher pH (near Boston, MA).

Sorry for the length, but I wanted to be thorough. What are the top reasons I could of ended up with a low efficiency.

2
Ingredients / Hops turned slightly brown. Can I dry hop with them?
« on: January 17, 2013, 03:42:46 PM »
Hey All,
Need help quickly. I am doing a 1.5IPA and I intend to dry hop. I had used some pellet hops during the boil about a week ago, but I saved roughly 1/2 ounce for dry hopping (galaxy hops). When I went to get them out of the fridge today, they seem a little brown. I intend on dry hopping today during some still pretty good fermentation (day 5). The yeast are still healthy enough to take care of some oxygen.

I was wondering if they brown hops are going to add any off flavors. The hops only appear to be slightly browner but still smell good.

Anyone have any experience with this?

3
Brewed a Kolsch this weekend. This was only the 2nd or 3rd beer that I used a yeast starter on. I followed Mr. Malty for setting it up. About 150g for 1600 ml starter. Yeast was European Ale from White Labs. Kolsch was an extract kit.

Long story short, some neighbors came over, and so the last bit of the brew day is a little fuzzy. I recorded an OG at 1.051. I pitched the yeast at around 65F.

I woke up the next day (~18 hours after pitching) and saw no signs of fermentation. This went on for about 4 days. I do work during the day, but I didn't see a bubble in the morning or night. I decided to check the gravity today and it is at 1.010! Not sure when it happened but it happened fast. 

It has a little bit of an off smell and kind a hot taste. Will this dissipate with the cold aging i had planned on doing for this style? Should I even bother racking and locking up a secondary for the next 6 weeks?

I know not to always trust the initial flavors and smells. The smell is almost like a sulfur, and the hot taste makes me think I fermented too fast.


Any thoughts?

4
General Homebrew Discussion / Phenol Contamination... Can I save it?
« on: November 18, 2011, 07:49:10 PM »
So I am not sure where exactly this fits, because it covers quite a few things.

I brewed a high gravity IPA in late August. I fermented for two weeks, and then racked to a secondary. After about 5 weeks in the secondary, I put the beer into a keg. My OG was 1.070 and my current is 1.017.

Here is my 1st issue, last night I tried a sample and I ( and my girl friend who isn't big on beer) both tasted the dread flavor of medicine. There is just enough sweetness that this beer actually tastes kind of like medicine. I had planned on dry hopping and/or potentially trying to pitch some champagne yeast. I was thinking that if the champagne yeast took care of some of the sweetness or if the dry hopping covered up some of the off-flavors that this beer might be drinkable.

Why would the fermentation stop with so much seemingly left to go?

Is it worth trying to save? It was a pretty expensive recipe to just throw it away now. I also am not sure at which point the contamination happened. I normally don't age beer this long, but I was really hoping to see a further drop in gravity.

Thoughts? Other than replacing tubing is there a common technique issue that could cause this? FWIW I have a Kolsch at the end of fermentation that has no noticeable off flavor, so I don't think it is my plastic fermenter.   

Pages: [1]