Author Topic: March pump issues  (Read 648 times)

Offline Pi

  • Brewer
  • ****
  • Posts: 310
  • "I would never trade tomorrow for today"
    • View Profile
March pump issues
« on: February 25, 2013, 04:16:16 PM »
Its the one on the BK side to the CFWC. sometimes it doesnt want to pump. or it will start and quit in a few seconds. I tried lowering it but still has the same problem. i think it might be cavitating. i ordered a new impeller from Morebeer hope it corrects the problem. anyone else ever have this problem?
Primary:Stella Rosemary IPA
Lagering: Sto Lat Gratzer
Drinking: Whenever I'm not working or driving

Offline tschmidlin

  • I must live here
  • **********
  • Posts: 8130
  • Redmond, WA
    • View Profile
Re: March pump issues
« Reply #1 on: February 25, 2013, 04:42:55 PM »
I've been having that problem - just today I turned it off and turned it back on and that fixed it.  Must be a windows OS pump :)

Sometimes I burp the fittings to let air out, that seems to help.
Tom Schmidlin

Online mtnrockhopper

  • I spend way too much time on the AHA forum
  • ********
  • Posts: 2876
  • Delaware
    • View Profile
Re: March pump issues
« Reply #2 on: February 26, 2013, 02:32:52 PM »
Have you seen this thread about pump head orientation?
 
http://www.homebrewersassociation.org/forum/index.php?topic=11157.0
Jimmy K

Delmarva United Homebrewers - President by inverse coup when the old president ousted himself.
AHA Member since 2006
BJCP: B0958

Offline dcbc

  • Brewer
  • ****
  • Posts: 269
    • View Profile
Re: March pump issues
« Reply #3 on: February 26, 2013, 03:13:41 PM »
How hot is the liquid you are trying to pump?  If it is boiling, cavitation is likely the issue.  The new impeller is a definite improvement.  But lately, I don't recirculate during the boil.  I just hit it once the flame is extinguished.
I've consumed all of my home brew and still can't relax!  Now what!

Offline Pi

  • Brewer
  • ****
  • Posts: 310
  • "I would never trade tomorrow for today"
    • View Profile
Re: March pump issues
« Reply #4 on: March 07, 2013, 11:04:48 AM »
Have you seen this thread about pump head orientation?
 
http://www.homebrewersassociation.org/forum/index.php?topic=11157.0
Thank you so much for directing me to this thread. I have installed the new impeller and changed the orientation and Seems to work. Next test is to try recirculating with boiling water. My goal is to get enough flow to create a whirlpool in the BK while pushing the wort through the CFWC.
Primary:Stella Rosemary IPA
Lagering: Sto Lat Gratzer
Drinking: Whenever I'm not working or driving