Author Topic: 1.070 expected Heavy proteins after boil and transfer  (Read 393 times)

Offline Timothy Frisbie

  • 1st Kit
  • *
  • Posts: 3
1.070 expected Heavy proteins after boil and transfer
« on: February 02, 2020, 06:24:54 pm »
First time I used a hops basket for the boil. At 15 min when putting chiller coil and new hops lost boil and turned up heat.
Boil came back hard, had another hot break and calmed down last 10 min. Left hops basket in during chill down and removed it and coils together. Shook out the hops screen fairly aggressively.

Went to pour into my fermenter and noticed much heavier hops and protein content. Way more than when I did the boils with the hops just tossed in!
Had to pour through my dry hop screen when transferring to fastferment. Got a lot of hop matter.
Fermenter Full to the 1 Gal mark of proteins / trub. just pitched yeast 4 hours ago and sitting 75 degrees f.

What happened, never had this much trub/. Cannot get a good SpG reading as my spigot is just below the 1 gal mark and all I get is crap!

Offline majorvices

  • Global Moderator
  • I must live here
  • *****
  • Posts: 11103
  • Polka. If its too loud you're too young.
1.070 expected Heavy proteins after boil and transfer
« Reply #1 on: February 03, 2020, 05:42:20 am »
Sounds like you had a good hot break. Maybe you hit your pH closer?. Maybe you just aren’t used to seeing hot break aside from hops? Regardless this is not a bad thing


Sent from my iPhone using Tapatalk
« Last Edit: February 03, 2020, 05:51:57 am by majorvices »

Offline Kevin

  • Brewmaster
  • *****
  • Posts: 576
  • Great beer. Less work. More fun.
Re: 1.070 expected Heavy proteins after boil and transfer
« Reply #2 on: February 03, 2020, 09:03:18 am »
Did you whirlpool or let the wort sit before transferring out of the boil kettle?
“He was a wise man who invented beer.”
- Plato

Offline Timothy Frisbie

  • 1st Kit
  • *
  • Posts: 3
Re: 1.070 expected Heavy proteins after boil and transfer
« Reply #3 on: February 03, 2020, 04:19:11 pm »
Thank you, I let it sit for 30 imputes during cool down, no whirlpool as I had too much stuff in my kettle (should have taken out the hops basket before cool down.. that and the chiller coils alway disrupts my whirlpool so I have stopped.
No the really ugly, I always am at a good fermentation at this time, always. 24 hours and it bubbling very strong, but no. Not this one no action at all....