Author Topic: Tower of Power Issue  (Read 139 times)

Offline duboman

  • Senior Brewmaster
  • ******
  • Posts: 1578
Tower of Power Issue
« on: September 26, 2020, 09:40:48 PM »
Haven't been around for a while but getting back to brewing. Turned on the Tower of power for my Brew Easy today to get a batch going. First got no contact error, cleaned sensor and seemed to clear that problem, gas ignited but ignitor kept clicking and then shuts down. Is this an ignitor issue, solenoid, or sensor failure. Seems it's not reading the flame? Any assistance is appreciated! I'm having shoulder surgery in 2 weeks and I'd like to get another beer on tap for the recovery :)
Peace....Love......Beer......

The Commune Brewing Company-Perfecting the craft of beer since 2010

Offline Bob357

  • Brewmaster
  • *****
  • Posts: 500
  • Consensus means nothing to me. I am who I am.
Re: Tower of Power Issue
« Reply #1 on: September 27, 2020, 06:59:16 AM »
I think you'd probably ne better off contacting Blichmann support for an answer. They are the experts.
Beer is my bucket list,

Bob357
Fallon, NV

Offline KellerBrauer

  • Brewmaster
  • *****
  • Posts: 564
  • Bottoms Up!
Re: Tower of Power Issue
« Reply #2 on: September 27, 2020, 12:21:48 PM »
I think you'd probably ne better off contacting Blichmann support for an answer. They are the experts.

👍🏽

Absolutely the best approach.
Joliet, IL

All good things come to those who show patients and perseverance while maintaining a positive and progressive attitude. 😉

Offline duboman

  • Senior Brewmaster
  • ******
  • Posts: 1578
Re: Tower of Power Issue
« Reply #3 on: September 27, 2020, 12:41:43 PM »
Thanks, I have but they're kinda slow to respond to things. I know there are a lot of Blichmann users here as well as knowledgeable electric brewers and I can't imagine this is a highly technical engineering question.
Peace....Love......Beer......

The Commune Brewing Company-Perfecting the craft of beer since 2010