Author Topic: did i kill my yeast/  (Read 624 times)

Offline brewbarr

  • 1st Kit
  • *
  • Posts: 12
    • View Profile
did i kill my yeast/
« on: September 13, 2010, 06:10:12 PM »
brewed new batch yesterday thought i was ready for yeast sprinkled it over my batch hoping to find my fermenter farting up a storm so far nothing...... did i kill it? thought all my temps were good but nothing .this is my first batch in a while and i didnt rehydrate the yeast was that my problem? can i fix it or give up? ???
Beer today Beer tomorrow:)

Offline bluesman

  • Global Moderator
  • I must live here
  • *****
  • Posts: 8808
  • Delaware
    • View Profile
Re: did i kill my yeast/
« Reply #1 on: September 13, 2010, 07:01:00 PM »
What was your recipe?  What temp did you pitch?  Need a little more specifics.

Thanks.
Ron Price

Offline wingnut

  • Brewer
  • ****
  • Posts: 310
  • Plainwell MI
    • View Profile
Re: did i kill my yeast/
« Reply #2 on: September 13, 2010, 07:07:28 PM »
Most likely you just killed half the yeast by not re-hydrating... which translates into a longer lag time as the yeast multiply to make up the difference. 

If it was a high gravity beer... above 1.070 or so... the yeast damage may have been even more.

So if you have another yeast packet, pitch it and you will be fine.  If you do not, wait a day, and you will "probably" be fine.

Good luck
-- Wingnut - Cheers!

Offline tschmidlin

  • I must live here
  • **********
  • Posts: 8197
  • Redmond, WA
    • View Profile
Re: did i kill my yeast/
« Reply #3 on: September 13, 2010, 07:18:09 PM »
24 hours isn't that long to wait based on what you've told us of your procedure.  I agree, if you have more yeast or can get one go ahead and add it.  If not, just give it another day and you should see some activity.
Tom Schmidlin